summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2019-12-13 13:53:47 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-15 00:34:05 +0100
commit4ac5d4fee19aad08289ed10da15e32d937ea595d (patch)
treee80a9af1c62469623d449616ae1e1cff66f9f7a5 /gnu/packages/commencement.scm
parent178e5500347ec25e777207310e44d5f598a3ddef (diff)
downloadguix-patches-4ac5d4fee19aad08289ed10da15e32d937ea595d.tar
guix-patches-4ac5d4fee19aad08289ed10da15e32d937ea595d.tar.gz
gnu: Add gfortran-toolchain
* gnu/packages/commencement.scm: (gfortran-toolchain): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 68030376fc..14ecf246d4 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2601,4 +2601,17 @@ an d binaries, plus debugging symbols in the @code{debug} output), and Binutils
(define-public gcc-toolchain-9
(make-gcc-toolchain gcc-9))
+;; Provide the Fortran toolchain package only for the version of gfortran that
+;; is used by Guix internally to build Fortran libraries, because combining
+;; code compiled with different versions can cause problems.
+
+(define-public gfortran-toolchain
+ (package (inherit (make-gcc-toolchain gfortran))
+ (synopsis "Complete GCC tool chain for Fortran development")
+ (description "This package provides a complete GCC tool chain for
+Fortran development to be installed in user profiles. This includes
+gfortran, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
+
+
;;; commencement.scm ends here