summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-14 16:26:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-14 16:28:22 +0100
commit48b97be90bbbdf3108e70d9e23bc8f296d4451b5 (patch)
treede09985a57c6b92d7dbcd1308eb8c8b7fa0c1c3e /gnu/packages/commencement.scm
parent9c9912cf5bffa9c7e2cb3e05ca7649ea295fa3ca (diff)
downloadguix-patches-48b97be90bbbdf3108e70d9e23bc8f296d4451b5.tar
guix-patches-48b97be90bbbdf3108e70d9e23bc8f296d4451b5.tar.gz
Revert "gnu: Add replacement for static-bash-for-glibc."
This reverts commit c4fb2b9f4e9ca1c5b586090b765b51b2a5042eff.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 94847b019a..fe9fbebcc2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -556,14 +556,6 @@ the bootstrap environment."
;; because we don't want to depend on bootstrap tools.
("static-bash" ,@(assoc-ref %boot0-inputs "bash")))))))
-(define patched-glibc-final-with-bootstrap-bash
- (package
- (inherit glibc-final-with-bootstrap-bash)
- (source (origin
- (inherit (package-source glibc-final-with-bootstrap-bash))
- (patches (cons (search-patch "glibc-allow-kernel-2.6.32.patch")
- (origin-patches (package-source glibc-final-with-bootstrap-bash))))))))
-
(define (cross-gcc-wrapper gcc binutils glibc bash)
"Return a wrapper for the pseudo-cross toolchain GCC/BINUTILS/GLIBC
that makes it available under the native tool names."
@@ -640,40 +632,6 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
("libc:static" ,glibc-final-with-bootstrap-bash "static")
,@(fold alist-delete %boot1-inputs
'("gcc" "libc")))))
- (let ((p (package-with-bootstrap-guile
- (package-with-explicit-inputs bash inputs
- (current-source-location)
- #:guile %bootstrap-guile))))
- (package (inherit p)
- (replacement patched-static-bash-for-glibc)))))
-
-;; Same as static-bash-for-glibc, except that it uses a patched glibc for the
-;; "gcc" and "bash" packages.
-(define patched-static-bash-for-glibc
- ;; A statically-linked Bash to be used by GLIBC-FINAL in system(3) & co.
- (let* ((gcc (cross-gcc-wrapper gcc-boot0 binutils-boot0
- patched-glibc-final-with-bootstrap-bash
- (car (assoc-ref %boot1-inputs "bash"))))
- (bash (package
- (inherit static-bash)
- (arguments
- (substitute-keyword-arguments
- (package-arguments static-bash)
- ((#:guile _ #f)
- '%bootstrap-guile)
- ((#:configure-flags flags '())
- ;; Add a '-L' flag so that the pseudo-cross-ld of
- ;; BINUTILS-BOOT0 can find libc.a.
- `(append ,flags
- (list (string-append "LDFLAGS=-static -L"
- (assoc-ref %build-inputs
- "libc:static")
- "/lib"))))))))
- (inputs `(("gcc" ,gcc)
- ("libc" ,patched-glibc-final-with-bootstrap-bash)
- ("libc:static" ,patched-glibc-final-with-bootstrap-bash "static")
- ,@(fold alist-delete %boot1-inputs
- '("gcc" "libc")))))
(package-with-bootstrap-guile
(package-with-explicit-inputs bash inputs
(current-source-location)