summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-02 17:11:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-02 17:11:17 +0200
commit3cff86db8a510bc2731b9899a6035ebda5225adc (patch)
tree980953ac51514f060e5d816beab70879440d82c4 /gnu/packages/commencement.scm
parent67ca82e6ddc9f1c87fa8c033729a1f53b7c2b3ba (diff)
downloadguix-patches-3cff86db8a510bc2731b9899a6035ebda5225adc.tar
guix-patches-3cff86db8a510bc2731b9899a6035ebda5225adc.tar.gz
gnu: Python: Move arm-alignment.patch to a native-input + phase.
This follows up 67ca82e6ddc9f1c87fa8c033729a1f53b7c2b3ba which was ineffective when running 'guix build --system=armhf-linux python' on e.g. x86_64-linux because the conditional would always return the native system. * gnu/packages/python.scm (python-3.8)[native-inputs]: Add "arm-alignment.patch". [arguments]: Add phase to apply it. [source](patches): Remove it. * gnu/packages/commencement.scm (python-boot0): Prevent inheriting the phase.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4c51fa0cf1..7e969faafe 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3182,7 +3182,17 @@ the bootstrap environment."
;; Python package won't interfere with this one.
((#:make-flags _ ''()) ''())
((#:phases phases)
- `(modify-phases ,phases
+ ;; Remove the 'apply-alignment-patch' phase if present to avoid
+ ;; rebuilding this package. TODO: for the next rebuild cycle,
+ ;; consider inlining all the arguments instead of inheriting to
+ ;; make it easier to patch Python without risking a full rebuild.
+ ;; Or better yet, change to 'python-on-guile'.
+ `(modify-phases ,@(list (match phases
+ (('modify-phases original-phases
+ changes ...
+ ('add-after unpack apply-alignment-patch _))
+ `(modify-phases ,original-phases ,@changes))
+ (_ phases)))
(add-before 'configure 'disable-modules
(lambda _
(substitute* "setup.py"