summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-19 19:02:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:41 +0100
commit3670ea70e2e932969a3ffc0acf75a714c7b42540 (patch)
tree0952c6fa93c68bb506a936a2ab25a59b33f0bbed /gnu/packages/commencement.scm
parent01e8263febb9634564b4b73af49b81a36567a11b (diff)
downloadguix-patches-3670ea70e2e932969a3ffc0acf75a714c7b42540.tar
guix-patches-3670ea70e2e932969a3ffc0acf75a714c7b42540.tar.gz
gnu: glibc-final-with-bootstrap-bash: Don't enable obsolete rpc.
* gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash) [arguments]: Remove 'enable-obsolete-rpc' configure flag. This brings this glibc package in line with the other glibc packages which are also built without the pre-2.14 glibc RPC functions. These functions cause build failures on armhf-linux and aarch64-linux.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 92a67acede..a76867f426 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1874,11 +1874,7 @@ the bootstrap environment."
((#:configure-flags flags)
`(append (list ,(string-append "--host=" (boot-triplet))
,(string-append "--build="
- (nix-system->gnu-triplet))
-
- ;; Build Sun/ONC RPC support. In particular,
- ;; install rpc/*.h.
- "--enable-obsolete-rpc")
+ (nix-system->gnu-triplet)))
,flags))
((#:phases phases)
`(modify-phases ,phases