summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-03 18:00:54 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-04 23:35:32 +0100
commit32793c09ffd07e8ca54fc5c3d992454b39add506 (patch)
treeb96abd8a00a827f31e7bac4ddb9c46f759b357da /gnu/packages/commencement.scm
parent7e1a74da93319a3b413854a052af1e9ccca02bdc (diff)
downloadguix-patches-32793c09ffd07e8ca54fc5c3d992454b39add506.tar
guix-patches-32793c09ffd07e8ca54fc5c3d992454b39add506.tar.gz
gnu: commencement: Memoize uses of 'cross-gcc-wrapper'.
This improves caching down the road. * gnu/packages/commencement.scm (gcc-boot0-intermediate-wrapped) (gcc-boot0-wrapped): Use 'mlambda' instead of 'lambda'.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 54746151ce..b022a0d634 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2070,12 +2070,13 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
("bash" ,bash)))
(inputs '())))
-(define (gcc-boot0-intermediate-wrapped)
- ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
- ;; non-cross names.
- (cross-gcc-wrapper gcc-boot0 binutils-boot0
- glibc-final-with-bootstrap-bash
- (car (assoc-ref (%boot1-inputs) "bash"))))
+(define gcc-boot0-intermediate-wrapped
+ (mlambda ()
+ ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
+ ;; non-cross names.
+ (cross-gcc-wrapper gcc-boot0 binutils-boot0
+ glibc-final-with-bootstrap-bash
+ (car (assoc-ref (%boot1-inputs) "bash")))))
(define static-bash-for-glibc
;; A statically-linked Bash to be used by GLIBC-FINAL in system(3) & co.
@@ -2166,11 +2167,12 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
,@(package-arguments glibc-final-with-bootstrap-bash)))))
-(define (gcc-boot0-wrapped)
- ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
- ;; non-cross names.
- (cross-gcc-wrapper gcc-boot0 binutils-boot0 glibc-final
- (car (assoc-ref (%boot1-inputs) "bash"))))
+(define gcc-boot0-wrapped
+ (mlambda ()
+ ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
+ ;; non-cross names.
+ (cross-gcc-wrapper gcc-boot0 binutils-boot0 glibc-final
+ (car (assoc-ref (%boot1-inputs) "bash")))))
(define (%boot2-inputs)
;; 3rd stage inputs.