summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-17 12:10:24 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-17 12:25:29 +0200
commit1380be3c73bb8734622df8972f80f9a5bfaf06dd (patch)
tree0d5f59ddd2b080aa467d5321e8141445ab4befff /gnu/packages/commencement.scm
parent2c35ae82192fd6f1732b15fa41aec87aa61a1879 (diff)
downloadguix-patches-1380be3c73bb8734622df8972f80f9a5bfaf06dd.tar
guix-patches-1380be3c73bb8734622df8972f80f9a5bfaf06dd.tar.gz
gnu: commencement: '%bootstrap-inputs+toolchain' no longer contains Mes.
* gnu/packages/commencement.scm (%bootstrap-inputs+toolchain): On i686-linux and x86_64-linux, remove "bootstrap-mescc-tools" and "mes" from %BOOTSTRAP-INPUTS.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 13b813f806..9a5f6b0929 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1388,15 +1388,16 @@ exec " gcc "/bin/" program
(define (%bootstrap-inputs+toolchain)
;; The traditional bootstrap-inputs. For the i686-linux Reduced Binary Seed
;; the actual reduced set with bootstrapped toolchain.
- (append (match (%current-system)
- ((or "i686-linux" "x86_64-linux")
- `(("libc" ,glibc-mesboot)
- ("binutils" ,binutils-mesboot)
- ("gcc-wrapper" ,gcc-mesboot-wrapper)
- ("gcc" ,gcc-mesboot)))
- (_
- '()))
- (%bootstrap-inputs)))
+ (match (%current-system)
+ ((or "i686-linux" "x86_64-linux")
+ `(("libc" ,glibc-mesboot)
+ ("binutils" ,binutils-mesboot)
+ ("gcc-wrapper" ,gcc-mesboot-wrapper)
+ ("gcc" ,gcc-mesboot)
+ ,@(fold alist-delete (%bootstrap-inputs)
+ '("bootstrap-mescc-tools" "mes"))))
+ (_
+ (%bootstrap-inputs))))
(define gnu-make-boot0
(package-with-bootstrap-guile