summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:38:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit0e2b817732539c496d3310e42eb4ea5340e8e570 (patch)
treebe717ce1a0f0808e996f29ac39b17dc3f77b0898 /gnu/packages/commencement.scm
parent2aab587f842908a886e3bd08b028885dddd650e0 (diff)
downloadguix-patches-0e2b817732539c496d3310e42eb4ea5340e8e570.tar
guix-patches-0e2b817732539c496d3310e42eb4ea5340e8e570.tar.gz
gnu: glibc: Absorb powerpc patch.
* gnu/packages/base.scm (glibc)[source]: Add patch. [arguments]: Remove 'apply-patch phase. [native-inputs]: Remove patch file. * gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash, glibc-final)[native-inputs]: Remove patch file.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e9d531c07e..f6bfc27843 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3218,11 +3218,7 @@ memoized as a function of '%current-system'."
`(("bison" ,bison-boot0)
("texinfo" ,texinfo-boot0)
("perl" ,perl-boot0)
- ("python" ,python-boot0)
- ,@(if (target-powerpc?)
- `(("powerpc64le-patch" ,@(search-patches
- "glibc-ldd-powerpc.patch")))
- '())))
+ ("python" ,python-boot0)))
(inputs
`( ;; The boot inputs. That includes the bootstrap libc. We don't want
;; it in $CPATH, hence the 'pre-configure' phase above.
@@ -3366,10 +3362,6 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; This time we need 'msgfmt' to install all the libc.mo files.
(native-inputs `(,@(package-native-inputs glibc-final-with-bootstrap-bash)
- ,@(if (target-powerpc?)
- `(("powerpc64le-patch" ,@(search-patches
- "glibc-ldd-powerpc.patch")))
- '())
("gettext" ,gettext-boot0)))
(propagated-inputs