summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-02 19:13:23 +0200
committerMarius Bakke <marius@gnu.org>2021-05-05 23:29:36 +0200
commit0e2251fcf8189a4f642074d3aa898221b29c3a55 (patch)
tree1945ab1def2a53d75deb5763dcc157d80b0efdac /gnu/packages/commencement.scm
parentd6104e3b85fe95bc74319df091a85cfb05aa3e4c (diff)
downloadguix-patches-0e2251fcf8189a4f642074d3aa898221b29c3a55.tar
guix-patches-0e2251fcf8189a4f642074d3aa898221b29c3a55.tar.gz
gnu: linux-libre-headers: Remove rsync dependency.
The resulting packages are bit-identical, sans for a missing empty "uapi" directory in versions < 5.3. * gnu/packages/commencement.scm (rsync-boot0): Remove variable. (linux-libre-headers-boot0)[native-inputs]: Remove RSYNC-BOOT0. * gnu/packages/linux.scm (make-linux-libre-headers*)[native-inputs]: Remove RSYNC. [arguments]: For newer kernel versions, run "make headers" instead of "make headers_check" before installing. Use FIND-FILES and INSTALL-FILE instead of calling "make headers_install". Remove ".install" files workaround.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 36ebcee163..b50c308ed3 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -50,7 +50,6 @@
#:use-module (gnu packages shells)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages rsync)
#:use-module (gnu packages xml)
#:use-module (guix gexp)
#:use-module (guix packages)
@@ -2916,15 +2915,6 @@ exec " gcc "/bin/" program
#:guile ,%bootstrap-guile
#:tests? #f))))
-(define rsync-boot0
- (package
- (inherit rsync)
- (native-inputs `(("perl" ,perl-boot0)))
- (inputs (%boot0-inputs))
- (arguments
- `(#:implicit-inputs? #f
- #:guile ,%bootstrap-guile))))
-
(define-syntax define/system-dependent
(lambda (s)
"Bind IDENTIFIER to EXP, where the value of EXP is known to depend on
@@ -2960,9 +2950,6 @@ memoized as a function of '%current-system'."
;; Flex and Bison are required since version 4.16.
("flex" ,flex-boot0)
("bison" ,bison-boot0)
-
- ;; Rsync is required since version 5.3.
- ("rsync" ,rsync-boot0)
,@(%boot0-inputs)))))
(define with-boot0