summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/code.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar
guix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm34
1 files changed, 29 insertions, 5 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index d52621dfcb..b9267b0f21 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -64,6 +64,7 @@
#:use-module (gnu packages perl-compression)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
@@ -137,17 +138,26 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(base32
"0g4aslm2zajq605py11s4rs1wdnzcqhkh7bc2xl5az42adzzg839"))))
(build-system gnu-build-system)
- (inputs `(("coreutils" ,coreutils)
- ("ncurses" ,ncurses)
- ("libltdl" ,libltdl)
- ("sqlite" ,sqlite)
- ("python-wrapper" ,python-wrapper)))
+ (inputs
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("coreutils" ,coreutils)
+ ("ctags" ,universal-ctags)
+ ("libltdl" ,libltdl)
+ ("ncurses" ,ncurses)
+ ("python-pygments" ,python-pygments)
+ ("python-wrapper" ,python-wrapper)
+ ("sqlite" ,sqlite)))
(arguments
`(#:configure-flags
(list (string-append "--with-ncurses="
(assoc-ref %build-inputs "ncurses"))
(string-append "--with-sqlite3="
(assoc-ref %build-inputs "sqlite"))
+ (string-append "--with-universal-ctags="
+ (assoc-ref %build-inputs "ctags") "/bin/ctags")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out") "/share/gtags")
+ "--localstatedir=/var" ; This needs to be a writable location.
"--disable-static")
#:phases
@@ -158,6 +168,20 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(assoc-ref inputs "coreutils") "/bin/echo")))
(substitute* "globash/globash.in"
(("/bin/echo") echo)))))
+ (add-after 'post-install 'install-plugins
+ (lambda _
+ (with-directory-excursion "plugin-factory"
+ (invoke "make" "install"))))
+ (add-before 'install 'dont-install-to-/var
+ (lambda _
+ (substitute* "gozilla/Makefile"
+ (("DESTDIR\\)\\$\\{localstatedir\\}") "TMPDIR)"))))
+ (add-after 'install-plugins 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program
+ (string-append (assoc-ref outputs "out")
+ "/share/gtags/script/pygments_parser.py")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
;; Install the plugin files in the right place.