summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-22 02:16:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-23 04:36:36 +0200
commitadbcc3ed8c11d50356f538b865fd1ca99f413ecc (patch)
tree9958a6224c57a35b04142648333fa4a8fe4fd37c /gnu/packages/code.scm
parentbfc0a2ffa8a551b71fd59e58932125f5f87bbb02 (diff)
downloadguix-patches-adbcc3ed8c11d50356f538b865fd1ca99f413ecc.tar
guix-patches-adbcc3ed8c11d50356f538b865fd1ca99f413ecc.tar.gz
gnu: lcov: Update to 1.15.
* gnu/packages/code.scm (lcov): Update to 1.15. [source]: Use a release tarball. [inputs]: Replace perl-perlio-gzip with perl-io-compress.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm91
1 files changed, 42 insertions, 49 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 7cdd0cc8d6..6d348308ac 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -470,60 +470,53 @@ stack traces.")
(license license:gpl3+)))
(define-public lcov
- ;; Use a recent commit from upstream since the latest official release
- ;; (1.14) doesn't support GCC 9 (see:
- ;; https://github.com/linux-test-project/lcov/issues/58).
- (let* ((commit "40580cd65909bc8324ae09b36bca2e178652ff3f")
- (revision "0")
- (version (git-version "1.14" revision commit)))
- (package
- (name "lcov")
- (version "1.14")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/linux-test-project/lcov")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0shgmh6fzhnj1qfdl90jgjmlbb1ih1qh879dca8hc58yggy3hqgb"))))
- (build-system gnu-build-system)
- (arguments
- '(#:test-target "test"
- #:make-flags (list (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-pwd
- ;; Lift the requirement of having a shell in PATH.
- (lambda _
- (substitute* "bin/geninfo"
- (("qw/abs_path/")
- "qw/abs_path getcwd/"))
- (substitute* '("bin/lcov" "bin/geninfo")
- (("`pwd`")
- "getcwd()"))
- #t))
- (delete 'configure) ;no configure script
- (add-after 'install 'wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/geninfo")
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
- #t)))))
- (inputs `(("perl" ,perl)
- ("perl-json" ,perl-json)
- ("perl-perlio-gzip" ,perl-perlio-gzip)))
- (home-page "http://ltp.sourceforge.net/coverage/lcov.php")
- (synopsis "Code coverage tool that enhances GNU gcov")
- (description "LCOV is an extension of @command{gcov}, a tool part of the
+ (package
+ (name "lcov")
+ (version "1.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/linux-test-project/lcov"
+ "/releases/download/v" version
+ "/lcov-" version ".tar.gz"))
+ (sha256
+ (base32 "0fh5z0q5wg2jxr2nn5w7321y0zg9rwk75j3k5hnamjdy6gxa5kf1"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:make-flags (list (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-pwd
+ ;; Lift the requirement of having a shell in PATH.
+ (lambda _
+ (substitute* "bin/geninfo"
+ (("qw/abs_path/")
+ "qw/abs_path getcwd/"))
+ (substitute* '("bin/lcov" "bin/geninfo")
+ (("`pwd`")
+ "getcwd()"))
+ #t))
+ (delete 'configure) ;no configure script
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/geninfo")
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
+ #t)))))
+ (inputs `(("perl" ,perl)
+ ("perl-io-compress" ,perl-io-compress)
+ ("perl-json" ,perl-json)))
+ (home-page "http://ltp.sourceforge.net/coverage/lcov.php")
+ (synopsis "Code coverage tool that enhances GNU gcov")
+ (description "LCOV is an extension of @command{gcov}, a tool part of the
GNU@tie{}Binutils, which provides information about what parts of a program
are actually executed (i.e., \"covered\") while running a particular test
case. The extension consists of a set of Perl scripts which build on the
textual @command{gcov} output to implement the following enhanced
functionality such as HTML output.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public kcov
(package