summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-12 14:47:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-12 14:47:10 +0200
commit9d9951d6a6d5b1cce55f52c1600032360fe3a25d (patch)
treebc5180af22d3864bd5afaa1e4d40224089b6df43 /gnu/packages/code.scm
parent94c3a6f1a628c71f07ebc78b2eb75afa3c47bfa1 (diff)
downloadguix-patches-9d9951d6a6d5b1cce55f52c1600032360fe3a25d.tar
guix-patches-9d9951d6a6d5b1cce55f52c1600032360fe3a25d.tar.gz
gnu: global: Use modify-phases syntax.
* gnu/packages/code.scm (global)[arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index e0d4997b31..754a435347 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -111,18 +111,17 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(string-append "--with-sqlite3="
(assoc-ref %build-inputs "sqlite")))
- #:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install the Emacs Lisp file in the right place.
- (let* ((out (assoc-ref outputs "out"))
- (data (string-append out "/share/gtags"))
- (lisp (string-append out "/share/emacs/site-lisp")))
- (install-file (string-append data "/gtags.el")
- lisp)
- (delete-file (string-append data "/gtags.el"))
- #t))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install the Emacs Lisp file in the right place.
+ (let* ((out (assoc-ref outputs "out"))
+ (data (string-append out "/share/gtags"))
+ (lisp (string-append out "/share/emacs/site-lisp")))
+ (install-file (string-append data "/gtags.el") lisp)
+ (delete-file (string-append data "/gtags.el"))
+ #t))))))
(home-page "http://www.gnu.org/software/global/")
(synopsis "Cross-environment source code tag system")
(description