summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-24 02:34:08 -0400
committerMark H Weaver <mhw@netris.org>2018-05-24 02:34:08 -0400
commit9d10a63402e3c3dcda288b9370d04568dfa20ea6 (patch)
tree12705e0e3752f73d309a0387bb75674e83d33062 /gnu/packages/code.scm
parent4935701a4a31212e0cf1b2375832fb7ecd3d8809 (diff)
parent11c237f54e4de5916e204aba574ab15f7818a3f5 (diff)
downloadguix-patches-9d10a63402e3c3dcda288b9370d04568dfa20ea6.tar
guix-patches-9d10a63402e3c3dcda288b9370d04568dfa20ea6.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm119
1 files changed, 119 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index d636945176..edf0f98aca 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -7,6 +7,10 @@
;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -529,3 +533,118 @@ produce colored output.")
output is a graphviz-dot file, a Gexf-XML file or a list of the deepest
independent targets.")
(license license:expat)))
+
+(define-public uncrustify
+ (package
+ (name "uncrustify")
+ (version "0.67")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/uncrustify/uncrustify/archive/"
+ "uncrustify-" version ".zip"))
+ (sha256
+ (base32
+ "0n13kq0nsm35fxhdp0f275n4x0w88hdv3bdjy0hgvv42x0dx5zyp"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-etc
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Configuration samples are not installed by default.
+ (let* ((output (assoc-ref outputs "out"))
+ (etcdir (string-append output "/etc")))
+ (for-each (lambda (l)
+ (install-file l etcdir))
+ (find-files "etc" "\\.cfg$")))
+ #t)))))
+ (home-page "http://uncrustify.sourceforge.net/")
+ (synopsis "Code formatter for C and other related languages")
+ (description
+ "Beautify source code in many languages of the C family (C, C++, C#,
+Objective@tie{}C, D, Java, Pawn, and Vala). Features:
+@itemize
+@item Indent and align code.
+@item Reformat comments (a little bit).
+@item Fix inter-character spacing.
+@item Add or remove parens / braces.
+@item Supports embedded SQL @code{EXEC SQL} stuff.
+@item Highly configurable - More than 600 configurable options.
+@end itemize\n")
+ (license license:gpl2+)))
+
+(define-public astyle
+ (package
+ (name "astyle")
+ (version "2.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/astyle/astyle/astyle%20"
+ version "/astyle_" version "_linux.tar.gz"))
+ (sha256
+ (base32
+ "0f9sh9kq5ajp1yz133h00fr9235p1m698x7n3h7zbrhjiwgynd6s"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags (list (string-append "prefix=" %output)
+ "INSTALL=install"
+ "all")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _ (chdir "build/gcc") #t))
+ (add-after 'install 'install-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Libraries are not installed by default
+ (let* ((output (assoc-ref outputs "out"))
+ (libdir (string-append output "/lib")))
+ (begin
+ (mkdir-p libdir)
+ (for-each (lambda (l)
+ (copy-file
+ l (string-append libdir "/" (basename l))))
+ (find-files "bin" "lib*"))))
+ #t)))))
+ (home-page "http://astyle.sourceforge.net/")
+ (synopsis "Source code indenter, formatter, and beautifier")
+ (description
+ "Artistic Style is a source code indenter, formatter, and beautifier for
+the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
+ (license license:lgpl3+)))
+
+(define-public indent
+ (package
+ (name "indent")
+ (version "2.2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/indent/indent-" version
+ ".tar.gz"))
+ (sha256 (base32
+ "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-docdir
+ (lambda _
+ ;; Although indent uses a modern autoconf in which docdir
+ ;; defaults to PREFIX/share/doc, the doc/Makefile.am
+ ;; overrides this to be in PREFIX/doc. Fix this.
+ (substitute* "doc/Makefile.in"
+ (("^docdir = .*$") "docdir = @docdir@\n"))
+ #t)))))
+ (synopsis "Code reformatter")
+ (description
+ "Indent is a program that makes source code easier to read by
+reformatting it in a consistent style. It can change the style to one of
+several different styles such as GNU, BSD or K&R. It has some flexibility to
+deal with incomplete or malformed syntax. GNU indent offers several
+extensions over the standard utility.")
+ (license license:gpl3+)
+ (home-page "https://www.gnu.org/software/indent/")))