summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 13:40:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-11 20:17:50 +0000
commit9526ce9bf1d581a92154696ce4509e1ed5d7beb5 (patch)
treea9a6ee73a6a0b769907f04ca64fae34ada3ecf7c /gnu/packages/code.scm
parent0c408f8b3ed6a4f5dbce168bc512a0baac5e48c6 (diff)
downloadguix-patches-9526ce9bf1d581a92154696ce4509e1ed5d7beb5.tar
guix-patches-9526ce9bf1d581a92154696ce4509e1ed5d7beb5.tar.gz
gnu: global: Remove input labels.
* gnu/packages/code.scm (global)[inputs]: Remove input labels. [arguments]: Adjust.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 5bfe719a70..fcd83b4568 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -139,15 +139,6 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(base32
"1kaphc3gml89p8dpdgh2is8hj46wj05689kxj0bmh5q759rxk4vg"))))
(build-system gnu-build-system)
- (inputs
- `(("bash" ,bash-minimal) ; for wrap-program
- ("coreutils" ,coreutils)
- ("ctags" ,universal-ctags)
- ("libltdl" ,libltdl)
- ("ncurses" ,ncurses)
- ("python-pygments" ,python-pygments)
- ("python-wrapper" ,python-wrapper)
- ("sqlite" ,sqlite)))
(arguments
`(#:configure-flags
(list (string-append "--with-ncurses="
@@ -155,7 +146,7 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(string-append "--with-sqlite3="
(assoc-ref %build-inputs "sqlite"))
(string-append "--with-universal-ctags="
- (assoc-ref %build-inputs "ctags") "/bin/ctags")
+ (assoc-ref %build-inputs "universal-ctags") "/bin/ctags")
(string-append "--sysconfdir="
(assoc-ref %outputs "out") "/share/gtags")
"--localstatedir=/var" ; This needs to be a writable location.
@@ -200,6 +191,15 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(string-append vim "/gtags.vim"))
(rename-file (string-append data "/gtags-cscope.vim")
(string-append vim "/gtags-cscope.vim"))))))))
+ (inputs
+ (list bash-minimal ; for wrap-program
+ coreutils
+ universal-ctags
+ libltdl
+ ncurses
+ python-pygments
+ python-wrapper
+ sqlite))
(home-page "https://www.gnu.org/software/global/")
(synopsis "Cross-environment source code tag system")
(description