summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-09 21:09:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-09 21:09:47 +0200
commit7fe6dcf70809b8aa4a94f9bb4aa6f0743bf66d21 (patch)
tree4c495910fc2431d6bd81079bfe2b227fec43e627 /gnu/packages/code.scm
parent33f460addfcc737a7a80dab244211811283b77f7 (diff)
downloadguix-patches-7fe6dcf70809b8aa4a94f9bb4aa6f0743bf66d21.tar
guix-patches-7fe6dcf70809b8aa4a94f9bb4aa6f0743bf66d21.tar.gz
gnu: Remove indent@2.2.10.
* gnu/packages/code.scm (indent): Update to 2.2.12. [native-inputs]: Add TEXINFO. (indent-2.2.12): Remove variable.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm21
1 files changed, 5 insertions, 16 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index c5dfa4aa7a..13e2c4ad44 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -626,13 +626,13 @@ the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
(define-public indent
(package
(name "indent")
- (version "2.2.10")
+ (version "2.2.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/indent/indent-" version
".tar.gz"))
- (sha256 (base32
- "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
+ (sha256
+ (base32 "12xvcd16cwilzglv9h7sgh4h1qqjd1h8s48ji2dla58m4706hzg7"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -645,6 +645,8 @@ the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
(substitute* "doc/Makefile.in"
(("^docdir = .*$") "docdir = @docdir@\n"))
#t)))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
(synopsis "Code reformatter")
(description
"Indent is a program that makes source code easier to read by
@@ -655,19 +657,6 @@ extensions over the standard utility.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/indent/")))
-(define-public indent-2.2.12
- (package
- (inherit indent)
- (version "2.2.12")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/indent/indent-" version
- ".tar.gz"))
- (sha256
- (base32
- "12xvcd16cwilzglv9h7sgh4h1qqjd1h8s48ji2dla58m4706hzg7"))))
- (native-inputs `(("texinfo" ,texinfo)))))
-
(define-public amalgamate
(let* ((commit "c91f07eea1133aa184f652b8f1398eaf03586208")
(revision "0")