summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-06 22:45:23 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-21 18:23:33 +0100
commit62b8ae1a910d4b89287ead11bd2c18325e660bdf (patch)
tree92431c76d2e9e39a399f4551324cc75c8117bdcc /gnu/packages/code.scm
parent9c8814909a8bb5f57044eecbf4a6843e66beca07 (diff)
downloadguix-patches-62b8ae1a910d4b89287ead11bd2c18325e660bdf.tar
guix-patches-62b8ae1a910d4b89287ead11bd2c18325e660bdf.tar.gz
gnu: astyle: Create symlinks for .so files, too.
The Makefile only creates files with a versioned extension (.so.3.1.0), which are not picked up be cmake's `find_libarary()`. (Instead cmake picks up the static .a library.) Symlinks for .so.3 are required to avoid phase `verify-runpath` fails. * gnu/packages/code.scm(astyle)[argumements]<modules>: New element. <phases>{install-libs}: Add creating symlinks.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm26
1 files changed, 20 insertions, 6 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 20726cfebc..7656ee8739 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@goebel-consult.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -597,6 +598,9 @@ Objective@tie{}C, D, Java, Pawn, and Vala). Features:
#:make-flags (list (string-append "prefix=" %output)
"INSTALL=install"
"all")
+ #:modules ((guix build gnu-build-system) ;; FIXME use %default-modules
+ (guix build utils)
+ (ice-9 regex))
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -606,12 +610,22 @@ Objective@tie{}C, D, Java, Pawn, and Vala). Features:
;; Libraries are not installed by default
(let* ((output (assoc-ref outputs "out"))
(libdir (string-append output "/lib")))
- (begin
- (mkdir-p libdir)
- (for-each (lambda (l)
- (copy-file
- l (string-append libdir "/" (basename l))))
- (find-files "bin" "lib*"))))
+ (define (make-so-link sofile strip-pattern)
+ (symlink
+ (basename sofile)
+ (regexp-substitute #f
+ (string-match strip-pattern sofile)
+ 'pre)))
+ (mkdir-p libdir)
+ (for-each (lambda (l)
+ (copy-file
+ l (string-append libdir "/" (basename l))))
+ (find-files "bin" "lib*"))
+ (for-each
+ (lambda (sofile)
+ (make-so-link sofile "(\\.[0-9]){3}$") ;; link .so
+ (make-so-link sofile "(\\.[0-9]){2}$")) ;; link .so.3
+ (find-files libdir "lib.*\\.so\\..*")))
#t)))))
(home-page "http://astyle.sourceforge.net/")
(synopsis "Source code indenter, formatter, and beautifier")