summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-03 16:15:39 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:12 +0200
commit59bd4b90e8ffb960430d8659cc2dac0c19fe8217 (patch)
tree8d8b5528f7309e0e1a57cf51796e588e05ab6d1f /gnu/packages/code.scm
parent3fe8fe5360a0c53296d807a5109d6a94adc5d95f (diff)
downloadguix-patches-59bd4b90e8ffb960430d8659cc2dac0c19fe8217.tar
guix-patches-59bd4b90e8ffb960430d8659cc2dac0c19fe8217.tar.gz
gnu: indent: Fix aarch64 cross-compilation.
The packaged config.sub and config.guess do not have aarch64 support. Replace them by the ones from automake. * gnu/packages/code.scm (indent)[arguments]: Replace outdated config.sub and config.guess, taken from ... [native-inputs]: ... here, by adding automake. (indent-2.2.12)[native-inputs]: Inherit from indent native-inputs to keep automake that is added above.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 13e2c4ad44..50d6870bc7 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -29,6 +29,7 @@
(define-module (gnu packages code)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -644,9 +645,24 @@ the C, C++, C++/CLI, Objective‑C, C#, and Java programming languages.")
;; overrides this to be in PREFIX/doc. Fix this.
(substitute* "doc/Makefile.in"
(("^docdir = .*$") "docdir = @docdir@\n"))
+ #t))
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (with-directory-excursion "config"
+ (for-each (lambda (file)
+ (install-file
+ (string-append (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess")))
#t)))))
(native-inputs
- `(("texinfo" ,texinfo)))
+ `(("texinfo" ,texinfo)
+ ("automake" ,automake))) ; For up to date 'config.guess' and 'config.sub'.
(synopsis "Code reformatter")
(description
"Indent is a program that makes source code easier to read by