summaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-30 19:14:04 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-30 19:14:04 +0100
commit0084aaf3d4a959c0ea33ed617784590ec3b45e9a (patch)
tree8c3a7ae410043370e7469ebd51fe3b88d99db761 /gnu/packages/code.scm
parent0c1910ed036438adf7acaab0423cc85920eb66d9 (diff)
downloadguix-patches-0084aaf3d4a959c0ea33ed617784590ec3b45e9a.tar
guix-patches-0084aaf3d4a959c0ea33ed617784590ec3b45e9a.tar.gz
gnu: Add lcov.
* gnu/packages/code.scm (lcov): New variable.
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 86b131a3e8..e8c936849a 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -280,3 +280,35 @@ stack traces.")
;; Sources are released under Expat license, but since BFD is licensed
;; under the GPLv3+ the combined work is GPLv3+ as well.
(license license:gpl3+)))
+
+(define-public lcov
+ (package
+ (name "lcov")
+ (version "1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ltp/lcov-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13xq2ln4jjasslqzzhr5g11q1c19gwpng1jphzbzmylmrjz62ila"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)
+ (string-append "BIN_DIR=" out "/bin")
+ (string-append "MAN_DIR=" out "/share/man")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ;no 'check' target
+ (inputs `(("perl" ,perl)))
+ (home-page "http://ltp.sourceforge.net/coverage/lcov.php")
+ (synopsis "Code coverage tool that enhances GNU gcov")
+ (description
+ "LCOV is an extension of @command{gcov}, a tool part of the
+GNU@tie{}Binutils, which provides information about what parts of a program
+are actually executed (i.e., \"covered\") while running a particular test
+case. The extension consists of a set of Perl scripts which build on the
+textual @command{gcov} output to implement the following enhanced
+functionality such as HTML output.")
+ (license license:gpl2+)))