summaryrefslogtreecommitdiff
path: root/gnu/packages/cobol.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 06:54:48 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 06:54:58 +0100
commit80739ea480a7db667b83b45e3a08be740449f689 (patch)
tree66156a8c753a926031c1e756c78adc33a5995e38 /gnu/packages/cobol.scm
parentca15eaeb069716892b9e060e7920460147f052bb (diff)
downloadguix-patches-80739ea480a7db667b83b45e3a08be740449f689.tar
guix-patches-80739ea480a7db667b83b45e3a08be740449f689.tar.gz
gnu: gnucobol: Update to 3.1.2 [security fixes].
* gnu/packages/cobol.scm (gnucobol): Update to 3.1.2. [arguments]: Add 'set-TERM phase before 'check to set the TERM environment variable for tests that expect it.
Diffstat (limited to 'gnu/packages/cobol.scm')
-rw-r--r--gnu/packages/cobol.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index 257527e3b8..bc191e6b09 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -30,7 +30,7 @@
(define-public gnucobol
(package
(name "gnucobol")
- (version "2.2")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
@@ -39,7 +39,7 @@
version ".tar.xz"))
(sha256
(base32
- "1814s1n95xax2dz938cf4fkcp0q94nkj1gjbdblbzpk9q92zq66w"))))
+ "0x15ybfm63g7c9340fc6712h9v59spnbyaz4rf85pmnp3zbhaw2r"))))
(arguments
'(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
@@ -49,7 +49,10 @@
(add-after 'unpack 'place-cobol85-test-suite
(lambda* (#:key inputs #:allow-other-keys)
(let ((newcob (assoc-ref inputs "newcob")))
- (copy-file newcob "tests/cobol85/newcob.val.Z")))))
+ (copy-file newcob "tests/cobol85/newcob.val.Z"))))
+ (add-before 'check 'set-TERM
+ ;; Some tests expect a known terminal
+ (lambda _ (setenv "TERM" "xterm-256color"))))
#:test-target "checkall"))
(native-inputs
`(("perl" ,perl)))