summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-22 07:41:45 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-25 12:18:55 +0300
commitffd526e61ab1b45c6c913ab4e139193e4d5bee9b (patch)
treee3bf5926628b3caf984ed10b484314c5b902b13b /gnu/packages/cmake.scm
parent475c11b1a7699e63467c0182da3602fbe6222378 (diff)
downloadguix-patches-ffd526e61ab1b45c6c913ab4e139193e4d5bee9b.tar
guix-patches-ffd526e61ab1b45c6c913ab4e139193e4d5bee9b.tar.gz
gnu: cmake: Delete Emacs library.
* gnu/packages/cmake.scm (cmake)[arguments]: Delete Emacs library.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 42391158c6..e43707389b 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -85,6 +85,13 @@
" --exclude-regex ^\\(" (string-join skipped-tests "\\|") "\\)$")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'split-package
+ ;; Remove files that have been packaged in other package recipes.
+ (lambda _
+ (delete-file "Auxiliary/cmake-mode.el")
+ (substitute* "Auxiliary/CMakeLists.txt"
+ ((".*cmake-mode.el.*") ""))
+ #t))
(add-before 'configure 'patch-bin-sh
(lambda _
;; Replace "/bin/sh" by the right path in... a lot of