summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-17 19:18:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-22 22:12:33 +0100
commitff5733d186839f32d1558a9e1f049d218613fa1a (patch)
tree98e2f53fa29c3454a48396ab2161217571f4e3fc /gnu/packages/cmake.scm
parent26edcd9b8db553bed324149bc039c306a804a2a3 (diff)
downloadguix-patches-ff5733d186839f32d1558a9e1f049d218613fa1a.tar
guix-patches-ff5733d186839f32d1558a9e1f049d218613fa1a.tar.gz
gnu: libjpeg-turbo: Build with a minimal variant of CMake.
This is necessary to avoid a circular dependency in the next commit. * gnu/packages/curl.scm (curl-minimal): New public variable. * gnu/packages/cmake.scm (cmake-minimal-bootstrap): New public variable. * gnu/packages/image.scm (libjpeg-turbo)[arguments]: Add #:cmake.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 21f11ac4f0..cf542f12e4 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -232,6 +232,18 @@ and workspaces that can be used in the compiler environment of your choice.")
(search-paths
(package-native-search-paths cmake-minimal))))
+;; The purpose of this package is to solve a circular dependency between
+;; packages that use cmake-build-system and CMakes own dependencies.
+(define-public cmake-minimal-bootstrap
+ (package
+ (inherit cmake-minimal)
+ (name "cmake-minimal-bootstrap")
+ (native-inputs
+ `(;; cURL depends on ghostscript (via groff and OpenLDAP), which depends on
+ ;; 'cmake-build-system' through libtiff and ultimately libjpeg-turbo.
+ ("curl" ,curl-minimal)
+ ,@(alist-delete "curl" (package-native-inputs cmake-minimal))))))
+
(define-public emacs-cmake-mode
(package
(inherit cmake)