summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-18 15:25:39 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-22 17:20:46 +0300
commitbbdf36666b82eae0a583d7124d8117801969570c (patch)
tree65859a03ceb2f6f33d018eef2a1274212510772d /gnu/packages/cmake.scm
parent0f5ad3a1bcdc20062ee3966296c5dcb99d0be6e9 (diff)
downloadguix-patches-bbdf36666b82eae0a583d7124d8117801969570c.tar
guix-patches-bbdf36666b82eae0a583d7124d8117801969570c.tar.gz
gnu: Add emacs-cmake-mode.
* gnu/packages/cmake.scm (emacs-cmake-mode): New public variable.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index e6c5c4e793..eba7a92c04 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -206,3 +206,20 @@ and workspaces that can be used in the compiler environment of your choice.")
(inputs
`(("rhash" ,rhash)
,@(package-inputs cmake)))))
+
+(define-public emacs-cmake-mode
+ (package
+ (inherit cmake)
+ (name "emacs-cmake-mode")
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-elisp
+ ;; Elisp directory is not in root of the source.
+ (lambda _
+ (chdir "Auxiliary"))))))
+ (synopsis "Emacs major mode for editing Cmake expressions")
+ (description "@code{cmakeos-mode} provides an Emacs major mode for editing
+Cmake files. It supports syntax highlighting, indenting and refilling of
+comments.")))