summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-06 23:01:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-06 23:01:48 +0200
commit87096247567ac0d4aac3fc5a7a1e150d307c5b80 (patch)
treec974ba45c8c82b98ddc83b6b2ecfdd224e0bc3b6 /gnu/packages/cmake.scm
parent116ca65b583ba4e404289f1481dc3a3ffef1c3dd (diff)
parent5e6bd3ebdcfad2bdb5c65427b5ebfe44a9e436d8 (diff)
downloadguix-patches-87096247567ac0d4aac3fc5a7a1e150d307c5b80.tar
guix-patches-87096247567ac0d4aac3fc5a7a1e150d307c5b80.tar.gz
Merge branch 'origin/core-updates-next' into core-updates
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 06b1cab82c..cc2d90712d 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -43,7 +43,7 @@
(define-public cmake
(package
(name "cmake")
- (version "3.11.0")
+ (version "3.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -51,7 +51,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "0sv5k9q6braa8hhw0y3w19avqn0xn5czv5jf5fz5blnlf7ivw4y3"))
+ "033x45q0lyaqr32pv92pv87pw20nja6i9794hmijrm6ilinbrgjp"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -86,6 +86,13 @@
" --exclude-regex ^\\(" (string-join skipped-tests "\\|") "\\)$")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'split-package
+ ;; Remove files that have been packaged in other package recipes.
+ (lambda _
+ (delete-file "Auxiliary/cmake-mode.el")
+ (substitute* "Auxiliary/CMakeLists.txt"
+ ((".*cmake-mode.el.*") ""))
+ #t))
(add-before 'configure 'patch-bin-sh
(lambda _
;; Replace "/bin/sh" by the right path in... a lot of