summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/cmake.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 3adda91fd3..36f8dcf8ff 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -83,7 +83,7 @@
(arguments
`(#:tests? #f)) ; No target
(native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (list extra-cmake-modules))
(synopsis "Shared CMake functions and macros")
(description "CMake-Shared are shared functions and macros for projects
using the CMake build system.")
@@ -291,8 +291,8 @@ and workspaces that can be used in the compiler environment of your choice.")
lstat)
#t))))
(inputs
- `(("jsoncpp" ,jsoncpp)
- ,@(package-inputs cmake-bootstrap)))
+ (modify-inputs (package-inputs cmake-bootstrap)
+ (prepend jsoncpp)))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -373,8 +373,9 @@ and workspaces that can be used in the compiler environment of your choice.")
(string-append doc html))
(delete-file-recursively (string-append out html)))))))))
(inputs
- `(("ncurses" ,ncurses) ;required for ccmake
- ,@(package-inputs cmake-minimal)))
+ (modify-inputs (package-inputs cmake-minimal)
+ (prepend ncurses ;required for ccmake
+ )))
;; Extra inputs required to build the documentation.
(native-inputs
`(,@(package-native-inputs cmake-minimal)