summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-25 14:19:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-25 14:19:14 +0100
commit7c1ea9316a3fd4212c08f8c3767dbd654d5136c6 (patch)
tree52f8a91dc689df172c3c025935c6fb70017c2cdc /gnu/packages/cmake.scm
parentfa8e0a5387419ba1edd17722329cdb27b1371ccf (diff)
downloadguix-patches-7c1ea9316a3fd4212c08f8c3767dbd654d5136c6.tar
guix-patches-7c1ea9316a3fd4212c08f8c3767dbd654d5136c6.tar.gz
gnu: cmake-minimal-bootstrap: Rename to cmake-bootstrap.
...and change the inheritance order while at it, to prepare for the next commit. * gnu/packages/cmake.scm (cmake-minimal): Rename to ... (cmake-bootstrap): ... this. [name]: Set to "cmake-bootstrap". [native-inputs]: Change from CURL to CURL-MINIMAL. (cmake-minimal-bootstrap): Remove variable. (cmake-minimal): New variable, inherits from CMAKE-BOOTSTRAP. * gnu/packages/image.scm (libjpeg-turbo)[arguments]: Change from CMAKE-MINIMAL-BOOTSTRAP to CMAKE-BOOTSTRAP.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 913317b25f..252ea1b065 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -47,11 +47,11 @@
#:use-module (gnu packages xml)
#:use-module (srfi srfi-1))
-;;; This minimal variant of CMake does not include the documentation. It is
-;;; used by the cmake-build-system.
-(define-public cmake-minimal
+;;; The "bootstrap" CMake. It is used to build the inputs of 'cmake-minimal'
+;;; below, to prevent a cyclic dependency on cmake-build-system.
+(define-public cmake-bootstrap
(package
- (name "cmake-minimal")
+ (name "cmake-bootstrap")
(version "3.16.3")
(source (origin
(method url-fetch)
@@ -156,7 +156,9 @@
(apply invoke "./configure" configure-flags))))))
(native-inputs
`(("bzip2" ,bzip2)
- ("curl" ,curl)
+ ;; cURL depends on ghostscript (via groff and OpenLDAP), which depends on
+ ;; 'cmake-build-system' through libtiff and ultimately libjpeg-turbo.
+ ("curl" ,curl-minimal)
("expat" ,expat)
("file" ,file)
("libarchive" ,libarchive)
@@ -194,6 +196,17 @@ and workspaces that can be used in the compiler environment of your choice.")
license:expat ; cmjsoncpp is dual MIT/public domain
license:public-domain)))) ; cmlibarchive/archive_getdate.c
+;;; This minimal variant of CMake does not include the documentation. It is
+;;; used by the cmake-build-system.
+(define-public cmake-minimal
+ (package
+ (inherit cmake-bootstrap)
+ (name "cmake-minimal")
+ (native-inputs
+ `(("curl" ,curl)
+ ,@(alist-delete "curl" (package-native-inputs cmake-bootstrap))))))
+
+;;; The "user-facing" CMake, now with manuals and HTML documentation.
(define-public cmake
(package
(inherit cmake-minimal)
@@ -236,18 +249,6 @@ and workspaces that can be used in the compiler environment of your choice.")
(search-paths
(package-native-search-paths cmake-minimal))))
-;; The purpose of this package is to solve a circular dependency between
-;; packages that use cmake-build-system and CMakes own dependencies.
-(define-public cmake-minimal-bootstrap
- (package
- (inherit cmake-minimal)
- (name "cmake-minimal-bootstrap")
- (native-inputs
- `(;; cURL depends on ghostscript (via groff and OpenLDAP), which depends on
- ;; 'cmake-build-system' through libtiff and ultimately libjpeg-turbo.
- ("curl" ,curl-minimal)
- ,@(alist-delete "curl" (package-native-inputs cmake-minimal))))))
-
(define-public emacs-cmake-mode
(package
(inherit cmake)