summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorIvan Vilata-i-Balaguer <ivan@selidor.net>2019-11-11 18:53:23 -0500
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 19:09:13 +0100
commit528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (patch)
tree3e46a2d6e32095f73cbb5bbb19f351f0395020c5 /gnu/packages/cmake.scm
parentba261f6318ed3f7232309e3bb7e435c401239b30 (diff)
downloadguix-patches-528b52390d216d8a8cd13dfcd1e6e40a6448e6c2.tar
guix-patches-528b52390d216d8a8cd13dfcd1e6e40a6448e6c2.tar.gz
gnu: CMake: Add version 3.15.5.
Add CMake version 3.15.5 but do not replace the existing version to avoid triggering the rebuild of all CMake-based packages. See <https://issues.guix.gnu.org/issue/38060>. * gnu/packages/cmake.scm (cmake-3.15.5): Add CMake 3.15.5. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 64349be444..e2c244c1a7 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -219,6 +219,22 @@ and workspaces that can be used in the compiler environment of your choice.")
(append (search-patches "cmake-curl-certificates.patch")
(origin-patches (package-source cmake))))))))
+(define-public cmake-3.15.5
+ ;; CMake 3.15.5 fixes some issues, but declare another version to
+ ;; avoid triggering the rebuild of all CMake-based packages.
+ ;; See <https://issues.guix.gnu.org/issue/38060>.
+ (package
+ (inherit cmake)
+ (version "3.15.5")
+ (source (origin
+ (inherit (package-source cmake))
+ (uri (string-append "https://www.cmake.org/files/v"
+ (version-major+minor version)
+ "/cmake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
+
(define-public emacs-cmake-mode
(package
(inherit cmake)