summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-21 03:34:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 14:50:50 +0100
commit4bbb7d48658a80dcbb2d03f51f0e3cbc1cd3bc11 (patch)
treec96e4504af4dea551d3fa0e5775bc31d7b2a55cb /gnu/packages/cmake.scm
parent8505eb19a4071f563811d4fe33471441c2db58b7 (diff)
downloadguix-patches-4bbb7d48658a80dcbb2d03f51f0e3cbc1cd3bc11.tar
guix-patches-4bbb7d48658a80dcbb2d03f51f0e3cbc1cd3bc11.tar.gz
gnu: cmake: Update to 3.7.2.
* gnu/packages/cmake.scm (cmake): Update to 3.7.2. [arguments]: Fix truthiness of some phases. [inputs]: Add LIBUV.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index cd82978de2..3ffa7d49f5 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -32,13 +32,14 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages file)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages xml))
(define-public cmake
(package
(name "cmake")
- (version "3.6.1")
+ (version "3.7.2")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -46,7 +47,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "04ggm9c0zklxypm6df1v4klrrd85m6vpv13kasj42za283n9ivi8"))
+ "1q6a60695prpzzsmczm2xrgxdb61fyjznb04dr6yls6iwv24c4nw"))
(patches (search-patches "cmake-fix-tests.patch"))))
(build-system gnu-build-system)
(arguments
@@ -72,7 +73,8 @@
"Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
"Tests/CMakeLists.txt"
"Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
- (("/bin/sh") (which "sh")))))
+ (("/bin/sh") (which "sh")))
+ #t))
(add-before 'configure 'set-paths
(lambda _
;; Help cmake's bootstrap process to find system libraries
@@ -80,7 +82,8 @@
(setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
(setenv "CMAKE_INCLUDE_PATH" (getenv "C_INCLUDE_PATH"))
;; Get verbose output from failed tests
- (setenv "CTEST_OUTPUT_ON_FAILURE" "TRUE"))))
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "TRUE")
+ #t)))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -106,6 +109,7 @@
("expat" ,expat)
("bzip2" ,bzip2)
("ncurses" ,ncurses) ; required for ccmake
+ ("libuv" ,libuv)
("libarchive" ,libarchive)))
(native-search-paths
(list (search-path-specification