summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-22 14:39:53 -0400
committerMark H Weaver <mhw@netris.org>2018-05-22 14:39:53 -0400
commit4935701a4a31212e0cf1b2375832fb7ecd3d8809 (patch)
treea3cae6f57e3c2ff47f9ad1518be8eb5ee0ac2915 /gnu/packages/cmake.scm
parentf037673c3133ae7453794f1f62eecebf9d06b092 (diff)
downloadguix-patches-4935701a4a31212e0cf1b2375832fb7ecd3d8809.tar
guix-patches-4935701a4a31212e0cf1b2375832fb7ecd3d8809.tar.gz
Revert "gnu: cmake: Delete Emacs library."
This reverts commit f037673c3133ae7453794f1f62eecebf9d06b092.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm6
1 files changed, 0 insertions, 6 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index c8f6f77b3a..e9fa866411 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -85,12 +85,6 @@
" --exclude-regex ^\\(" (string-join skipped-tests "\\|") "\\)$")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'split-package
- ;; Remove files that have been packaged in other package recipes.
- (lambda _
- (delete-file "Auxiliary/cmake-mode.el")
- (substitute* "Auxiliary/CMakeLists.txt"
- ((".*cmake-mode.el.*") ""))))
(add-before 'configure 'patch-bin-sh
(lambda _
;; Replace "/bin/sh" by the right path in... a lot of