summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-21 17:20:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:41:36 +0200
commit14767d4466c7f7bcf32c68b2d10cc359c79d7160 (patch)
treeae6ec404e44ab181b3556406bdb2ab726c189f8d /gnu/packages/cmake.scm
parent0a6e9e13c54fb8a4574c9e1eb4e6d243f45b12ae (diff)
downloadguix-patches-14767d4466c7f7bcf32c68b2d10cc359c79d7160.tar
guix-patches-14767d4466c7f7bcf32c68b2d10cc359c79d7160.tar.gz
gnu: CMake: Update to 3.15.1.
* gnu/packages/cmake.scm (cmake-minimal): Update to 3.15.1. [arguments]: Do not patch /bin/sh in removed file.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 8a0bba2e8f..387456be50 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -51,7 +51,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.14.5")
+ (version "3.15.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -59,7 +59,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "01lcl6ynxfgqn09ncfz1gr24ha5pv1slk0azzaawaqrwpsgf8njh"))
+ "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -125,7 +125,6 @@
(substitute*
'("Modules/CompilerId/Xcode-3.pbxproj.in"
"Modules/CPack.RuntimeScript.in"
- "Source/cmakexbuild.cxx"
"Source/cmGlobalXCodeGenerator.cxx"
"Source/cmLocalUnixMakefileGenerator3.cxx"
"Source/cmExecProgramCommand.cxx"