summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-02-24 18:18:08 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-03-23 11:32:33 +0530
commit12420c800e91026ea884c9643ff0df2d2e59d7f9 (patch)
tree5caf33fa31a74cefda822731bf181b96a7555aa4 /gnu/packages/cmake.scm
parent89db6c6de97d717c9c2b49d94305381f998b0ca2 (diff)
downloadguix-patches-12420c800e91026ea884c9643ff0df2d2e59d7f9.tar
guix-patches-12420c800e91026ea884c9643ff0df2d2e59d7f9.tar.gz
gnu: cmake: Re-indent.
* gnu/packages/cmake.scm (cmake): Re-indent.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm80
1 files changed, 40 insertions, 40 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index d5022dc741..ff011c7c14 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -44,29 +44,29 @@
(name "cmake")
(version "3.10.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://www.cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (sha256
- (base32
- "12r1ldq4l032d6f5gc22dlayck4cr29cczqsl9xf0vdm9anzml40"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Drop bundled software.
- (with-directory-excursion "Utilities"
- (for-each delete-file-recursively
- '("cmbzip2"
- ;; "cmcompress"
- "cmcurl"
- "cmexpat"
- ;; "cmjsoncpp"
- ;; "cmlibarchive"
- "cmliblzma"
- ;; "cmlibuv"
- "cmzlib"))
- #t)))))
+ (method url-fetch)
+ (uri (string-append "https://www.cmake.org/files/v"
+ (version-major+minor version)
+ "/cmake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12r1ldq4l032d6f5gc22dlayck4cr29cczqsl9xf0vdm9anzml40"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Drop bundled software.
+ (with-directory-excursion "Utilities"
+ (for-each delete-file-recursively
+ '("cmbzip2"
+ ;; "cmcompress"
+ "cmcurl"
+ "cmexpat"
+ ;; "cmjsoncpp"
+ ;; "cmlibarchive"
+ "cmliblzma"
+ ;; "cmlibuv"
+ "cmzlib"))
+ #t)))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -75,8 +75,8 @@
(list "BundleUtilities" ; This test fails on Guix.
"CTestTestSubdir" ; This test fails to build 2 of the 3 tests.
"CMake.String" ; This test depends on clock being set to
- ; current time, which is not the case in
- ; the build environment.
+ ; current time, which is not the case in
+ ; the build environment.
;; These tests requires network access.
"CTestCoverageCollectGCOV"
"CTestTestUpload")))
@@ -87,22 +87,22 @@
(modify-phases %standard-phases
(add-before 'configure 'patch-bin-sh
(lambda _
- ;; Replace "/bin/sh" by the right path in... a lot of
- ;; files.
- (substitute*
- '("Modules/CompilerId/Xcode-3.pbxproj.in"
- "Modules/CPack.RuntimeScript.in"
- "Source/cmakexbuild.cxx"
- "Source/cmGlobalXCodeGenerator.cxx"
- "Source/CTest/cmCTestBatchTestHandler.cxx"
- "Source/cmLocalUnixMakefileGenerator3.cxx"
- "Source/cmExecProgramCommand.cxx"
- "Utilities/Release/release_cmake.cmake"
- "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
- "Tests/CMakeLists.txt"
- "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
+ ;; Replace "/bin/sh" by the right path in... a lot of
+ ;; files.
+ (substitute*
+ '("Modules/CompilerId/Xcode-3.pbxproj.in"
+ "Modules/CPack.RuntimeScript.in"
+ "Source/cmakexbuild.cxx"
+ "Source/cmGlobalXCodeGenerator.cxx"
+ "Source/CTest/cmCTestBatchTestHandler.cxx"
+ "Source/cmLocalUnixMakefileGenerator3.cxx"
+ "Source/cmExecProgramCommand.cxx"
+ "Utilities/Release/release_cmake.cmake"
+ "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
+ "Tests/CMakeLists.txt"
+ "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
(("/bin/sh") (which "sh")))
- #t))
+ #t))
(add-before 'configure 'set-paths
(lambda _
;; Help cmake's bootstrap process to find system libraries