summaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
authorAndrew Whatson <whatson@gmail.com>2021-08-20 22:45:19 +1000
committerLudovic Courtès <ludo@gnu.org>2021-09-28 15:43:00 +0200
commit5c3f764aafda96ad9b8f8e3aca7cd6f66c519486 (patch)
treef65e19564cdd6f8b81eeab1ed67f6e583d6c3404 /gnu/packages/cluster.scm
parent62180be2ee342fb3a866531385e179563dae87a0 (diff)
downloadguix-patches-5c3f764aafda96ad9b8f8e3aca7cd6f66c519486.tar
guix-patches-5c3f764aafda96ad9b8f8e3aca7cd6f66c519486.tar.gz
gnu: libraft: Update to 0.11.2.
* gnu/packages/cluster.scm (libraft): Update to 0.11.2. [inputs]: Add lz4. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index e643cc58f9..5464c6dd4d 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -28,6 +28,7 @@
#:use-module (guix packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages libevent)
@@ -188,7 +189,7 @@ independently or together to provide resilient infrastructures.")
(define-public libraft
(package
(name "libraft")
- (version "0.10.1")
+ (version "0.11.2")
(home-page "https://github.com/canonical/raft")
(source (origin
(method git-fetch)
@@ -197,7 +198,7 @@ independently or together to provide resilient infrastructures.")
(file-name (git-file-name name version))
(sha256
(base32
- "18idj53vnl5fx1ja1zlp8kiwmdxgwjxsi88rdql0pbh0484b92a3"))))
+ "050dwy34jh8dihfwfm0r1by2i3sy9crapipp9idw32idm79y4izb"))))
(arguments '(#:configure-flags '("--enable-uv")
#:phases
(modify-phases %standard-phases
@@ -207,7 +208,8 @@ independently or together to provide resilient infrastructures.")
((".*test_uv_append.c.*") ""))
#t)))))
(inputs
- `(("libuv" ,libuv)))
+ `(("libuv" ,libuv)
+ ("lz4" ,lz4)))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)