summaryrefslogtreecommitdiff
path: root/gnu/packages/cinnamon.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-24 19:21:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-25 14:08:30 +0200
commit609ba8d1162cb44c5caae0ddabeb06c8e24550a5 (patch)
tree1374d05185122777942e76372157cb3799dbdbd1 /gnu/packages/cinnamon.scm
parentfea30e12f7b0810c90b278127a7d3c75ef59cec7 (diff)
downloadguix-patches-609ba8d1162cb44c5caae0ddabeb06c8e24550a5.tar
guix-patches-609ba8d1162cb44c5caae0ddabeb06c8e24550a5.tar.gz
gnu: cinnamon-desktop: Don't use unstable tarball.
* gnu/packages/cinnamon.scm (cinnamon-desktop)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/cinnamon.scm')
-rw-r--r--gnu/packages/cinnamon.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index 72403e1b11..a8850391aa 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
@@ -40,13 +42,14 @@
(name "cinnamon-desktop")
(version "3.4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/linuxmint/cinnamon-desktop/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmint/cinnamon-desktop")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1jf24csrbfi9aiza1g70jpvsbjiqwphk0i5wilxq9kpjjsl99maq"))))
+ "18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
(build-system gnu-build-system)
(arguments
`(#:phases