summaryrefslogtreecommitdiff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/ci.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm44
1 files changed, 18 insertions, 26 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index 652722c74a..2fa7260b7f 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -168,28 +168,24 @@
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,objs)))
#t))))))
(inputs
- `(("guile" ,guile-3.0-latest)
- ("guile-avahi" ,guile-avahi)
- ("guile-fibers" ,guile-fibers)
- ("guile-gcrypt" ,guile-gcrypt)
- ("guile-json" ,guile-json-4)
- ("guile-simple-zmq" ,guile-simple-zmq)
- ("guile-squee" ,guile-squee-dev)
- ("guile-git" ,guile-git)
- ("guile-zlib" ,guile-zlib)
- ("guile-mastodon" ,guile-mastodon)
- ("gnutls" ,gnutls)
- ("mailutils" ,mailutils)
- ;; FIXME: this is propagated by "guile-git", but it needs to be among
- ;; the inputs to add it to GUILE_LOAD_PATH.
- ("guile-bytestructures" ,guile-bytestructures)
- ("guix" ,guix)))
+ (list guile-3.0-latest
+ guile-avahi
+ guile-fibers
+ guile-gcrypt
+ guile-json-4
+ guile-simple-zmq
+ guile-squee-dev
+ guile-git
+ guile-zlib
+ guile-mastodon
+ gnutls
+ mailutils
+ ;; FIXME: this is propagated by "guile-git", but it needs to be among
+ ;; the inputs to add it to GUILE_LOAD_PATH.
+ guile-bytestructures
+ guix))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
- ("ephemeralpg" ,ephemeralpg)))
+ (list autoconf automake pkg-config texinfo ephemeralpg))
(native-search-paths
;; For HTTPS access, Cuirass itself honors these variables, with the
;; same semantics as Git and OpenSSL (respectively).
@@ -275,11 +271,7 @@ intended as a replacement for Hydra.")
#t)))))
(inputs
- `(("capnproto" ,capnproto)
- ("rapidjson" ,rapidjson)
- ("sqlite" ,sqlite)
- ("boost" ,boost)
- ("zlib" ,zlib)))
+ (list capnproto rapidjson sqlite boost zlib))
(native-inputs
`(("googletest" ,googletest)
("uglifyjs" ,node-uglify-js)