summaryrefslogtreecommitdiff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-09-07 09:36:28 -0400
committerKei Kebreau <kkebreau@posteo.net>2017-09-10 18:21:35 -0400
commit4561498e1f207e83ecc4a9fe1a08935c2807160f (patch)
tree4e679e479e1dc42219efcca417039989e76cc627 /gnu/packages/ci.scm
parent1e8d398abca66bbe85caad6d338ac80a104701d2 (diff)
downloadguix-patches-4561498e1f207e83ecc4a9fe1a08935c2807160f.tar
guix-patches-4561498e1f207e83ecc4a9fe1a08935c2807160f.tar.gz
gnu: Fix build failures caused by commit
d10092b849153dc27cfed0a9601fde6c7bdec918. * gnu/packages/bioinformatics.scm (seek)[arguments]: Restore previous phase order. * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index c449754be8..f3259bfcda 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -216,7 +216,12 @@ their dependencies.")
(substitute* "Makefile.am"
(("tests/repo.scm \\\\") "\\"))
#t))
- (add-after 'disable-repo-tests 'bootstrap
+ (add-after 'disable-repo-tests 'patch-/bin/sh
+ (lambda _
+ (substitute* "build-aux/git-version-gen"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t))
+ (add-after 'patch-/bin/sh 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)