summaryrefslogtreecommitdiff
path: root/gnu/packages/ci.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-10 17:03:49 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-10 22:09:13 +0200
commit0d43b12d1dc7c5bf0d86c71de140bff37025c7c2 (patch)
treee3ffacce093efe19e883030ab28bcdbe860adc17 /gnu/packages/ci.scm
parent99bde93b8392e5761f06a5b68b78dd433cacf096 (diff)
downloadguix-patches-0d43b12d1dc7c5bf0d86c71de140bff37025c7c2.tar
guix-patches-0d43b12d1dc7c5bf0d86c71de140bff37025c7c2.tar.gz
gnu: cuirass: Update snapshot; switch to Guile 2.2.
* gnu/packages/ci.scm (cuirass): Update to commit 870e8d6. Increment REVISION. [source]: Change URL to git.savannah.gnu.org. [arguments]: Add #:modules. In 'wrap-program' phase, get the Guile effective version and honor it. [inputs]: Use GUILE-2.2 instead of GUILE-2.0 and GUILE2.2-JSON instead of GUILE-JSON. [home-page]: Set to the Guix home page.
Diffstat (limited to 'gnu/packages/ci.scm')
-rw-r--r--gnu/packages/ci.scm35
1 files changed, 24 insertions, 11 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index ae91464a18..06a06dc65c 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -187,23 +187,28 @@ their dependencies.")
(license l:gpl3+))))
(define-public cuirass
- (let ((commit "8c811abb3174b44601b8996a1fe1718f37d7bd14")
- (revision "5"))
+ (let ((commit "870e8d6ad3415ac61c52e57095fcc6164023a0fc")
+ (revision "6"))
(package
(name "cuirass")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://notabug.org/mthl/cuirass")
+ (url "https://git.savannah.gnu.org/git/guix/guix-cuirass.git")
(commit commit)))
(file-name (string-append name "-" version))
(sha256
(base32
- "0kz2ys01xlmxagsfr9qf3p212vm31wfl76rvxa7ii5804aidlz5n"))))
+ "0lp5a5p42k7lml15lbmmd7az9i0gw5kips3sh3awd2z79h0w2knw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:modules ((guix build utils)
+ (guix build gnu-build-system)
+ (ice-9 rdelim)
+ (ice-9 popen))
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-repo-tests
(λ _
@@ -221,9 +226,17 @@ their dependencies.")
(sqlite (assoc-ref inputs "guile-sqlite3"))
(git (assoc-ref inputs "git"))
(guix (assoc-ref inputs "guix"))
- (mods (string-append json "/share/guile/site/2.0:"
- sqlite "/share/guile/site/2.0:"
- guix "/share/guile/site/2.0")))
+ (guile (assoc-ref %build-inputs "guile"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (mods (string-append json "/share/guile/site/"
+ effective ":"
+ sqlite "/share/guile/site/"
+ effective ":"
+ guix "/share/guile/site/"
+ effective)))
;; Make sure 'cuirass' can find the 'git' and 'evaluate'
;; commands, as well as the relevant Guile modules.
(wrap-program (string-append out "/bin/cuirass")
@@ -233,8 +246,8 @@ their dependencies.")
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,mods)))
#t))))))
(inputs
- `(("guile" ,guile-2.0)
- ("guile-json" ,guile-json)
+ `(("guile" ,guile-2.2)
+ ("guile-json" ,guile2.2-json)
("guile-sqlite3" ,guile-sqlite3)
("guix" ,guix)
("git" ,git)))
@@ -247,5 +260,5 @@ their dependencies.")
(description
"Cuirass is a continuous integration tool using GNU Guix. It is
intended as a replacement for Hydra.")
- (home-page "https://notabug.org/mthl/cuirass")
+ (home-page "https://www.gnu.org/software/guix/")
(license l:gpl3+))))