summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-20 22:47:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 22:49:32 +0200
commit9a2e5fe5fdcc6ea848ceeefa0f70147dfb360639 (patch)
treea8be3064a924e81b49171f0ba0d44c8cfb5fe736 /gnu/packages/chromium.scm
parent0605d939a91e9aa945bb09c2f41d4421dc1c6c0b (diff)
downloadguix-patches-9a2e5fe5fdcc6ea848ceeefa0f70147dfb360639.tar
guix-patches-9a2e5fe5fdcc6ea848ceeefa0f70147dfb360639.tar.gz
gnu: ungoogled-chromium: Disable parallel build.
* gnu/packages/chromium.scm (ungoogled-chromium)[arguments]: Set #:parallel-build? #f. Adjust 'build' phase to account for it.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index f3f91cc603..a1e40b9ba0 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -404,6 +404,9 @@ from forcing GEXP-PROMISE."
(build-system gnu-build-system)
(arguments
`(#:tests? #f
+ ;; Chromiums build processes may consume up to 8GiB of memory per core.
+ ;; Disable parallel builds to avoid thrashing end user systems.
+ #:parallel-build? #f
;; FIXME: Chromiums RUNPATH lacks entries for some libraries, so
;; we have to disable validation and add a wrapper below.
#:validate-runpath? #f
@@ -605,9 +608,11 @@ from forcing GEXP-PROMISE."
(format #t "Dumping configure flags...\n")
(invoke "gn" "args" "out/Release" "--list"))))
(replace 'build
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key (parallel-build? #t) #:allow-other-keys)
(invoke "ninja" "-C" "out/Release"
- "-j" (number->string (parallel-job-count))
+ "-j" (if parallel-build?
+ (number->string (parallel-job-count))
+ "1")
"chrome"
"chromedriver")))
(replace 'install