summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-22 15:44:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-22 17:10:23 +0100
commit718540d21bd013d2a27657f1247fcdb92fe8140f (patch)
tree6003c6fc0b304625ad8a7ce24daa99a58eaaee1e /gnu/packages/chromium.scm
parent28cbf65cb944606aafc8b07edd2c521ca58c3127 (diff)
downloadguix-patches-718540d21bd013d2a27657f1247fcdb92fe8140f.tar
guix-patches-718540d21bd013d2a27657f1247fcdb92fe8140f.tar.gz
gnu: ungoogled-chromium: Include Ungoogled revision in version string.
* gnu/packages/chromium.scm (package-revision, %package-version): New variables. (ungoogled-chromium-source)[file-name]: Use %PACKAGE-VERSION. (ungoogled-chromium)[version]: Likewise.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 17e15e307a..2c5f56263b 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -225,6 +225,11 @@ from forcing GEXP-PROMISE."
(define %chromium-version "72.0.3626.109")
(define %ungoogled-revision "a58db880c15e5077e881cad7b07d1a277ecd463a")
+(define package-revision "0")
+
+(define %package-version (string-append %chromium-version "-"
+ package-revision "."
+ (string-take %ungoogled-revision 7)))
;; This is a "computed" origin that does the following:
;; 1) Runs the Ungoogled scripts on a pristine Chromium tarball.
@@ -253,7 +258,7 @@ from forcing GEXP-PROMISE."
(origin
(method computed-origin-method)
- (file-name (string-append "ungoogled-chromium-" %chromium-version ".tar.xz"))
+ (file-name (string-append "ungoogled-chromium-" %package-version ".tar.xz"))
(sha256 #f)
(uri
(delay
@@ -347,7 +352,7 @@ depends = linux_rooted\n")))
(define-public ungoogled-chromium
(package
(name "ungoogled-chromium")
- (version %chromium-version)
+ (version %package-version)
(synopsis "Graphical web browser")
(source ungoogled-chromium-source)
(build-system gnu-build-system)