summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-21 23:32:04 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-22 16:22:21 +0200
commit6a489839a8852dc3428c53b0d35ead32e06dc1ac (patch)
tree2f8eb0a3a6e48d38d3ffdda17210c693fada7c8f /gnu/packages/chromium.scm
parent6fd4c6b2675b122fc9000756d0ae579356810191 (diff)
downloadguix-patches-6a489839a8852dc3428c53b0d35ead32e06dc1ac.tar
guix-patches-6a489839a8852dc3428c53b0d35ead32e06dc1ac.tar.gz
gnu: ungoogled-chromium: Enable parallel build.
...but limit the memory usage. Tested with --cores=8 on a 16 GiB RAM machine. * gnu/packages/chromium.scm (ungoogled-chromium)[arguments]: Remove <#:parallel-build?>. Add "jumbo_file_merge_limit=8" in <#:configure-flags>.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 90ce787416..d072fc58ad 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -408,9 +408,6 @@ from forcing GEXP-PROMISE."
(build-system gnu-build-system)
(arguments
`(#:tests? #f
- ;; Chromiums build processes may consume up to 8GiB of memory per core.
- ;; Disable parallel builds to avoid thrashing end user systems.
- #:parallel-build? #f
;; FIXME: Chromiums RUNPATH lacks entries for some libraries, so
;; we have to disable validation and add a wrapper below.
#:validate-runpath? #f
@@ -467,6 +464,9 @@ from forcing GEXP-PROMISE."
;; Optimize for building everything at once, as opposed to
;; incrementally for development. See "docs/jumbo.md".
"use_jumbo_build=true"
+ ;; The default file merge limit of 50 requires huge amounts of RAM.
+ ;; Cap it to make sure the build succeeds on commodity hardware.
+ "jumbo_file_merge_limit=8"
;; Prefer system libraries.
"use_system_freetype=true"