summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-21 16:25:37 +0200
committerMarius Bakke <marius@gnu.org>2021-10-22 12:09:23 +0200
commit39e6fec373c29e341dd6995694756df9d82264b8 (patch)
treeab426f9004cd333ca6d2f551efe46b6d61e9326d /gnu/packages/chromium.scm
parente8ef3b808d66fe7a7e73613dd7e57f42f9bb9d5f (diff)
downloadguix-patches-39e6fec373c29e341dd6995694756df9d82264b8.tar
guix-patches-39e6fec373c29e341dd6995694756df9d82264b8.tar.gz
gnu: ungoogled-chromium: Update to 95.0.4638.54-1.
* gnu/packages/chromium.scm (%chromium-version): Set to 95.0.4638.54. (%ungoogled-revision): Set to 95.0.4638.54. (%ungoogled-origin): Update hash. (ungoogled-chromium)[source]: Likewise. [arguments]: Remove obsolete configure flag. Adjust substitutions for 95.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 2b3f54e773..6683287258 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -336,8 +336,8 @@
(string-append "ungoogled-chromium-" category "-" name))))
(sha256 (base32 hash))))
-(define %chromium-version "94.0.4606.81")
-(define %ungoogled-revision "94.0.4606.81-1")
+(define %chromium-version "95.0.4638.54")
+(define %ungoogled-revision "95.0.4638.54-1")
(define %arch-revision "db2157b84924ce84201a8245e68a02f7d55f6491")
(define %debian-revision "debian/90.0.4430.85-1")
@@ -367,7 +367,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "113abybh8kkw9a92lj6jww6dl6rc1sv5x7a7a1gjwsihzd2r0cik"))))
+ "01jkkz5224aaj5cgdmqknf8v73fyaw4q8bzbqa520a0lvl7hwbg5"))))
(define %guix-patches
(list (local-file
@@ -502,7 +502,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "16755mfqxxmvslm9ix060safrnml91ckj5p85960jj5g5hmslwbh"))
+ "1zb1009gg9962axn2l1krycz7ml20i8z2n3ka2psxpg68pbqivry"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
@@ -598,7 +598,6 @@
"rtc_use_h264=true"
"rtc_use_pipewire=true"
"rtc_link_pipewire=true"
- "rtc_pipewire_version=\"0.3\""
;; Don't use bundled sources.
"rtc_build_json=true" ;FIXME: libc++ std::string ABI difference
"rtc_build_libevent=false"
@@ -651,15 +650,16 @@
""))
;; XXX: Should be unnecessary when use_system_lcms2=true.
- (substitute* "third_party/pdfium/core/fxcodec/icc/iccmodule.h"
+ (substitute* "third_party/pdfium/core/fxcodec/icc/icc_transform.h"
(("include \"third_party/lcms/include/lcms2\\.h\"")
"include \"lcms2.h\""))
- ;; Add missing include statement.
- (substitute* "third_party/pdfium/core/fxcodec/png/png_decoder.cpp"
- (("#include \"core/fxcodec/fx_codec.h\"" all)
- (string-append all
- "\n#include \"core/fxcodec/fx_codec_def.h\"")))
+ ;; Chromium bundles a pre-release of Harfbuzz 3.0 and uses an
+ ;; experimental API that was removed in 3.0. Adjust to use
+ ;; the updated API (taken from <https://crrev.com/c/3076563>).
+ (substitute* "components/paint_preview/common/subset_font.cc"
+ (("hb_subset_input_no_subset_tables_set\\(input\\.get\\(\\)\\)")
+ "hb_subset_input_set(input.get(), HB_SUBSET_SETS_NO_SUBSET_TABLE_TAG)"))
(substitute*
"third_party/breakpad/breakpad/src/common/linux/libcurl_wrapper.h"