summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-03 19:40:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-03 19:40:33 +0100
commit22c313eff8500cb7d8a370a6eaed95a5540af323 (patch)
tree0435714c1874375f961393fbd06ac7450d5889ef /gnu/packages/chromium.scm
parent95c633e0d8ed4b20cea3afc3afab1abdd2cc6c4b (diff)
downloadguix-patches-22c313eff8500cb7d8a370a6eaed95a5540af323.tar
guix-patches-22c313eff8500cb7d8a370a6eaed95a5540af323.tar.gz
gnu: Deprecate ungoogled-chromium.
This package has known security flaws that are being exploited in the wild. See <https://lists.gnu.org/archive/html/guix-devel/2019-10/msg00576.html> for why it has not been updated. * gnu/packages/chromium.scm (ungoogled-chromium)[properties]: Set #:hidden? #t. (ungoogled-chromium-is-deprecated, ungoogled-chromium-wayland-is-deprecated): New public variables.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index aad1fd9203..03d8c74640 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnuzilla)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -806,7 +807,10 @@ from forcing GEXP-PROMISE."
;; Building Chromium takes ... a very long time. On a single core, a busy
;; mid-end x86 system may need more than 24 hours to complete the build.
- (properties '((timeout . 144000))) ;40 hours
+ (properties '((timeout . 144000) ;40 hours
+
+ ;; Hide the package pending complete removal (see below).
+ (hidden? . #t)))
(home-page "https://github.com/Eloston/ungoogled-chromium")
(description
@@ -852,3 +856,13 @@ disabled in order to protect the users privacy.")
(assoc-ref %build-inputs "wayland")
"/bin/wayland-scanner\""))
(delete "use_vaapi=true" ,flags)))))))
+
+;; Ungoogled-Chromium has been deprecated because Debians patches are no
+;; longer updated. If you would like to work on porting the required patches,
+;; please reach out to guix-devel@gnu.org.
+
+(define-public ungoogled-chromium-is-deprecated
+ (deprecated-package "ungoogled-chromium" icecat))
+
+(define-public ungoogled-chromium-wayland-is-deprecated
+ (deprecated-package "ungoogled-chromium-wayland" icecat))