summaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-05 09:30:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-07 18:18:12 +0100
commit07b10725da1a9f69bd2619cfe67c0a455ecd8e3f (patch)
treebc7c1788426df0fb0842bf8deaf211293e5f6117 /gnu/packages/chromium.scm
parentf8157512a33c032261c903c9b39243a183640f01 (diff)
downloadguix-patches-07b10725da1a9f69bd2619cfe67c0a455ecd8e3f.tar
guix-patches-07b10725da1a9f69bd2619cfe67c0a455ecd8e3f.tar.gz
gnu: ungoogled-chromium: Lower resource limits.
* gnu/packages/chromium.scm (ungoogled-chromium)[arguments]: Decrease maximum number of open files from 4096 to 2048.
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index d31e0bcac5..dc8e041219 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -688,17 +688,17 @@ from forcing GEXP-PROMISE."
;; accesses. Having a too low ulimit will result in bogus linker
;; errors such as "foo.a: error adding symbols: malformed archive".
- ;; Try increasing the soft resource limit of max open files to 4096,
+ ;; Try increasing the soft resource limit of max open files to 2048,
;; or equal to the hard limit, whichever is lower.
(call-with-values (lambda () (getrlimit 'nofile))
(lambda (soft hard)
- (when (and soft (< soft 4096))
+ (when (and soft (< soft 2048))
(if hard
- (setrlimit 'nofile (min hard 4096) hard)
- (setrlimit 'nofile 4096 #f))
+ (setrlimit 'nofile (min hard 2048) hard)
+ (setrlimit 'nofile 2048 #f))
(format #t
"increased maximum number of open files from ~d to ~d~%"
- soft (if hard (min hard 4096) 4096)))))
+ soft (if hard (min hard 2048) 2048)))))
#t))
(replace 'build
(lambda* (#:key (parallel-build? #t) #:allow-other-keys)