summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/chicken.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 866ba8a062..d611c1762e 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -68,7 +68,7 @@
(variable "CHICKEN_REPOSITORY_PATH")
;; TODO extract binary version into a module level definition.
(files (list "var/lib/chicken/11")))))
- (propagated-inputs `(("gcc-toolchain" ,gcc-toolchain)))
+ (propagated-inputs (list gcc-toolchain))
(home-page "https://www.call-cc.org/")
(synopsis "R5RS Scheme implementation that compiles native code via C")
(description
@@ -99,7 +99,7 @@ language standard, and includes many enhancements and extensions.")
(build-system chicken-build-system)
(arguments '(#:egg-name "srfi-1"))
(inputs
- `(("chicken-test" ,chicken-test)))
+ (list chicken-test))
(home-page "https://wiki.call-cc.org/eggref/5/srfi-1")
(synopsis "SRFI-1 list library")
(description
@@ -182,11 +182,9 @@ CHICKEN Scheme, along with
;; TODO do we really have to make these propagated?
;; I don't know Chicken's module system well enough to tell
(propagated-inputs
- `(("chicken-datatype" ,chicken-datatype)
- ("chicken-srfi-1" ,chicken-srfi-1)
- ("chicken-srfi-14" ,chicken-srfi-14)))
+ (list chicken-datatype chicken-srfi-1 chicken-srfi-14))
(inputs
- `(("chicken-test" ,chicken-test)))
+ (list chicken-test))
(build-system chicken-build-system)
(arguments '(#:egg-name "agrep"))
(synopsis "Approximate string matching library")
@@ -217,8 +215,7 @@ file indexing tool.")
(build-system chicken-build-system)
(arguments '(#:egg-name "datatype"))
(inputs
- `(("chicken-srfi-1" ,chicken-srfi-1)
- ("chicken-test" ,chicken-test)))
+ (list chicken-srfi-1 chicken-test))
(home-page "https://wiki.call-cc.org/eggref/5/datatype")
(synopsis "Facility for creating and using variant records")
(description
@@ -245,7 +242,7 @@ Languages} by Friedman, Wand, and Haynes.")
(base32
"0gz50n5i561n5sk9prry0lrxz6bfrq9if5bclaq6a0f7lzinhnzb"))))
(inputs
- `(("chicken-test" ,chicken-test)))
+ (list chicken-test))
(build-system chicken-build-system)
(arguments '(#:egg-name "iset"))
(synopsis "Integer set library")