summaryrefslogtreecommitdiff
path: root/gnu/packages/chicken.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-28 20:09:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-15 20:17:36 +0200
commit7de49a0e014e57e8725d9b773814250e34eaf108 (patch)
tree14e9bb3faf15ddd97133b3e4844ae9dfdf1b2e96 /gnu/packages/chicken.scm
parent4ce7f1fb24a111f3e92d5b889d1271bebf109d09 (diff)
downloadguix-patches-7de49a0e014e57e8725d9b773814250e34eaf108.tar
guix-patches-7de49a0e014e57e8725d9b773814250e34eaf108.tar.gz
gnu: Add chicken-crypto-tools.
* gnu/packages/chicken.scm (chicken-crypto-tools): New variable.
Diffstat (limited to 'gnu/packages/chicken.scm')
-rw-r--r--gnu/packages/chicken.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index d611c1762e..c4e0a9c693 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -278,3 +278,34 @@ with integers.")
"This package provides a simple testing utility for CHICKEN Scheme.")
(license license:bsd-3)))
+(define-public chicken-crypto-tools
+ (package
+ (name "chicken-crypto-tools")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (egg-uri "crypto-tools" version))
+ (sha256
+ (base32
+ "0ajf0qfnhp99f4x1dll2fhlxrsxamgrrwyksc7rrym77xmv8f1pd"))))
+ (build-system chicken-build-system)
+ (arguments '(#:egg-name "crypto-tools"))
+ (home-page "https://wiki.call-cc.org/egg/crypto-tools")
+ (synopsis "Useful cryptographic primitives")
+ (description "The crypto-tools egg implements useful cryptographic
+primitives. More specifically, provided are:
+
+@itemize
+@item binary blobs
+@itemize
+@item marshallers to and from hex strings
+@item blob xor
+@item blob padding using either PKCS#5 or ISO7816-4
+@end itemize
+@item Block cipher modes of operation
+@itemize
+@item CBC with or without incorporated encrypted IV in the ciphertext
+@item CTR with or without incorporated IV in the ciphertext
+@end itemize
+@end itemize")
+ (license license:bsd-3)))