summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-29 16:15:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:39:24 +0200
commitfa63939acba69e11df44073a7eb687bd2ba48349 (patch)
tree6a074ca62733ca31b9e7669fdf076504d508dfcf /gnu/packages/chez.scm
parent67656b7a86e95dea2e0ff613dfe67ec8fb633604 (diff)
downloadguix-patches-fa63939acba69e11df44073a7eb687bd2ba48349.tar
guix-patches-fa63939acba69e11df44073a7eb687bd2ba48349.tar.gz
gnu: chez-scheme: Fix build failure in 'reset-gzip-timestamps' phase.
* gnu/packages/chez.scm (chez-scheme)[arguments]: Add 'make-manpages-writable' phase.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 6b2b70f19e..b532057605 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -190,7 +190,15 @@
(symlink file (string-append (dirname file)
"/" name ".boot")))
(find-files lib "scheme.boot"))
- #t))))))
+ #t)))
+ (add-before 'reset-gzip-timestamps 'make-manpages-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files (string-append (assoc-ref outputs "out")
+ "/share/man")
+ ".*\\.gz$"))
+ #t)))))
;; According to the documentation MIPS is not supported.
;; Cross-compiling for the Raspberry Pi is supported, but not native ARM.
(supported-systems (fold delete %supported-systems