summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 17:28:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:04 +0100
commit88c85a940335f6cd5472f9dff7ade29753ea5353 (patch)
tree2c43879efc0c242131c7b14ca29ce3e150b4795f /gnu/packages/chez.scm
parentf01b17b374b0354b14babe2d323191c729e87804 (diff)
downloadguix-patches-88c85a940335f6cd5472f9dff7ade29753ea5353.tar
guix-patches-88c85a940335f6cd5472f9dff7ade29753ea5353.tar.gz
gnu: chez-matchable: Don't use unstable tarball.
* gnu/packages/chez.scm (chez-matchable)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index fcf2a09bdc..04371c7413 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -435,11 +435,13 @@ Chez Scheme.")
(home-page "https://github.com/fedeinthemix/chez-matchable")
(source
(origin
- (method url-fetch)
- (uri (string-append home-page "/archive" "/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
(sha256
- (base32 "0cl4vc6487pikjq159pj4n5ghyaax31nywb5n4yn1682h3ir1hs0"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "02qn7x348p23z1x5lwhkyj7i8z6mgwpzpnwr8dyina0yzsdkr71s"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs
`(("chez-srfi" ,chez-srfi))) ; for tests