summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-20 22:18:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-21 06:57:16 +0200
commit7ceee88c4378c2bdcc454ddd43fc5f9ee89dbb2f (patch)
tree6448f438699b48fbaca2e726bd03ab57238d7300 /gnu/packages/chez.scm
parente48fcd7b8d07f213b23e3b432b0f10db917f69fa (diff)
downloadguix-patches-7ceee88c4378c2bdcc454ddd43fc5f9ee89dbb2f.tar
guix-patches-7ceee88c4378c2bdcc454ddd43fc5f9ee89dbb2f.tar.gz
gnu: chez-scheme: Properly identify system architecture.
* gnu/packages/chez.dcm (chez-scheme)[arguments]: Substitute `uname -m' for `uname -a' in configure, allowing proper identification of the machine architecture.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c3cb7d7659..5edce56505 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -100,6 +100,10 @@
'())))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-processor-detection
+ (lambda _ (substitute* "configure"
+ (("uname -a") "uname -m"))
+ #t))
;; Adapt the custom 'configure' script.
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)