summaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-23 12:37:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-23 12:37:17 +0200
commit1e16648f825b76a8feb63ce51e7ada8ae9870aa0 (patch)
treeeb0888c3553f5589944be1238abb756b831c0e73 /gnu/packages/chez.scm
parent08b3e4a97066c9baaf39e3df7c2dd9c39e693ead (diff)
downloadguix-patches-1e16648f825b76a8feb63ce51e7ada8ae9870aa0.tar
guix-patches-1e16648f825b76a8feb63ce51e7ada8ae9870aa0.tar.gz
gnu: chez-scheme: Remove support for armhf.
* gnu/packages/chez.scm (chez-scheme)[supported-systems]: Remove armhf-linux from the list of supported systems.
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5edce56505..7f0256edcc 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,8 +95,7 @@
(list ,(match (or (%current-target-system) (%current-system))
("x86_64-linux" '(list "--machine=ta6le"))
("i686-linux" '(list "--machine=ti3le"))
- ;; FIXME: Some people succeeded in cross-compiling to
- ;; ARM. https://github.com/cisco/ChezScheme/issues/13
+ ;; Let autodetection have its attempt on other architectures.
(_
'())))
#:phases
@@ -191,7 +191,9 @@
(find-files lib "scheme.boot"))
#t))))))
;; According to the documentation MIPS is not supported.
- (supported-systems (delete "mips64el-linux" %supported-systems))
+ ;; Cross-compiling for the Raspberry Pi is supported, but not native ARM.
+ (supported-systems (fold delete %supported-systems
+ '("mips64el-linux" "armhf-linux")))
(home-page "http://www.scheme.com")
(synopsis "R6RS Scheme compiler and run-time")
(description