summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-07-21 12:47:34 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-07-21 22:28:51 -0400
commiteb5ece73a84439d21219a802c0dcb88d54046371 (patch)
tree98c5f0d4ce0b3979d2d7d80f6d918171211c5889 /gnu/packages/chemistry.scm
parent889e7fab3c04be98a59b880bf44fbdaa6ddf0a4e (diff)
downloadguix-patches-eb5ece73a84439d21219a802c0dcb88d54046371.tar
guix-patches-eb5ece73a84439d21219a802c0dcb88d54046371.tar.gz
gnu: openbabel: Fix crash when opening NWChem output files.
* gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/chemistry.scm (openbabel)[source]: Use it.
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index a81c14b43c..418b4be2f4 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -213,7 +213,9 @@ NumPy < 1.9.")
version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "1z3d6xm70dpfikhwdnbzc66j2l49vq105ch041wivrfz5ic3ch90"))))
+ "1z3d6xm70dpfikhwdnbzc66j2l49vq105ch041wivrfz5ic3ch90"))
+ (patches
+ (search-patches "openbabel-fix-crash-on-nwchem-output.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags