summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-22 22:27:21 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-25 22:21:28 -0500
commitdaa4728efc14a3c4c3893ba5e4daeda4bbdabf75 (patch)
treefe2cfe3a5597cadcf1897c4b08b456ffb1d363f0 /gnu/packages/chemistry.scm
parentead609930f300c8bb274cc1659bb53441cf62df1 (diff)
downloadguix-patches-daa4728efc14a3c4c3893ba5e4daeda4bbdabf75.tar
guix-patches-daa4728efc14a3c4c3893ba5e4daeda4bbdabf75.tar.gz
gnu: Add mmtf-cpp.
* gnu/packages/chemistry.scm (mmtf-cpp): New variable.
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 129d6c1abe..2a42f6bcc8 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -242,6 +242,31 @@ analogy is that InChI is the bar-code for chemistry and chemical structures.")
"file://LICENCE"
"See LICENCE in the distribution."))))
+(define-public mmtf-cpp
+ (package
+ (name "mmtf-cpp")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcsb/mmtf-cpp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ylramda69plf5w0v5hxbl4ggkdi5s15z55cv0pljl12yvyva8l"))))
+ (build-system cmake-build-system)
+ ;; Tests require the soon-to-be-deprecated version 1 of the catch-framework.
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://mmtf.rcsb.org/")
+ (synopsis "C++ API for the Macromolecular Transmission Format")
+ (description "This package is a library for the
+@acronym{MMTF,macromolecular transmission format}, a binary encoding of
+biological structures.")
+ (license license:expat)))
+
(define with-numpy-1.8
(package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))