summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-01-05 17:06:22 +0100
committerLeo Famulari <leo@famulari.name>2018-01-05 16:19:09 -0500
commit73114e30cb46182f3dbc56cd6e142f3af19a12c3 (patch)
tree1085a83cf25c15743a92ff33740e571cf83a6205 /gnu/packages/chemistry.scm
parenta7a8590bdca66bff4e40a89097c3f94d1209cfb1 (diff)
downloadguix-patches-73114e30cb46182f3dbc56cd6e142f3af19a12c3.tar
guix-patches-73114e30cb46182f3dbc56cd6e142f3af19a12c3.tar.gz
gnu: Add domainfinder.
* gnu/packages/chemistry.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
new file mode 100644
index 0000000000..0cd1585e92
--- /dev/null
+++ b/gnu/packages/chemistry.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages chemistry)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (gnu packages python)
+ #:use-module (guix build-system python))
+
+(define-public domainfinder
+ (package
+ (name "domainfinder")
+ (version "2.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/khinsen/"
+ "domainfinder/downloads/DomainFinder-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1z26lsyf7xwnzwjvimmbla7ckipx6p734w7y0jk2a2fzci8fkdcr"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-mmtk" ,python2-mmtk)))
+ (arguments
+ `(#:python ,python-2
+ ;; No test suite
+ #:tests? #f))
+ (home-page "http://dirac.cnrs-orleans.fr/DomainFinder")
+ (synopsis "Analysis of dynamical domains in proteins")
+ (description "DomainFinder is an interactive program for the determination
+and characterization of dynamical domains in proteins. It can infer dynamical
+domains by comparing two protein structures, or from normal mode analysis on a
+single structure. The software is currently not actively maintained and works
+only with Python 2 and NumPy < 1.9.")
+ (license license:cecill-c)))