summaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-07-13 22:44:54 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-07-17 20:53:57 -0400
commit348edd91eff2c10448c4c5fc883e0cad3594adeb (patch)
tree45420d03aeb78fded89ef151ac2c5e06d54ef5fa /gnu/packages/chemistry.scm
parenta1e3da63cb4b9a9151849d1d4360c2a8415becb5 (diff)
downloadguix-patches-348edd91eff2c10448c4c5fc883e0cad3594adeb.tar
guix-patches-348edd91eff2c10448c4c5fc883e0cad3594adeb.tar.gz
gnu: Add openbabel.
* gnu/packages/chemistry.scm (openbabel): New variable.
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 1a5086d622..a81c14b43c 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -21,10 +21,14 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages compression)
#:use-module (gnu packages gv)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
@@ -198,3 +202,40 @@ neutron scattering spectra, but also computes other quantities. The software
is currently not actively maintained and works only with Python 2 and
NumPy < 1.9.")
(license license:cecill)))
+
+(define-public openbabel
+ (package
+ (name "openbabel")
+ (version "2.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z3d6xm70dpfikhwdnbzc66j2l49vq105ch041wivrfz5ic3ch90"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DOPENBABEL_USE_SYSTEM_INCHI=ON"
+ (string-append "-DINCHI_LIBRARY="
+ (assoc-ref %build-inputs "inchi")
+ "/lib/inchi/libinchi.so.1")
+ (string-append "-DINCHI_INCLUDE_DIR="
+ (assoc-ref %build-inputs "inchi") "/include/inchi"))
+ #:test-target "test"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("eigen" ,eigen)
+ ("inchi" ,inchi)
+ ("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
+ (home-page "http://openbabel.org/wiki/Main_Page")
+ (synopsis "Chemistry data manipulation toolbox")
+ (description
+ "Open Babel is a chemical toolbox designed to speak the many languages of
+chemical data. It's a collaborative project allowing anyone to search, convert,
+analyze, or store data from molecular modeling, chemistry, solid-state
+materials, biochemistry, or related areas.")
+ (license license:gpl2)))